Commit 72028590 authored by Aldo Ignacio Arriola Cordova's avatar Aldo Ignacio Arriola Cordova
Browse files

nuevo archivo desde jupyterhub

parent 82e19109
......@@ -3,3 +3,5 @@
Ejercicio paras la clase 4 de interacción con los repos
Aldo was here!
### Changed from clone!
%% Cell type:code id: tags:
``` python
import numpy as np
import matplotlib.pyplot as plt
```
%% Cell type:code id: tags:
``` python
%matplotlib qt
```
%%%% Output: error
---------------------------------------------------------------------------
ImportError Traceback (most recent call last)
<ipython-input-3-325c2f98aa22> in <module>
----> 1 get_ipython().run_line_magic('matplotlib', 'qt')
/usr/local/lib/python3.7/dist-packages/IPython/core/interactiveshell.py in run_line_magic(self, magic_name, line, _stack_depth)
2324 kwargs['local_ns'] = self.get_local_scope(stack_depth)
2325 with self.builtin_trap:
-> 2326 result = fn(*args, **kwargs)
2327 return result
2328
<decorator-gen-101> in matplotlib(self, line)
/usr/local/lib/python3.7/dist-packages/IPython/core/magic.py in <lambda>(f, *a, **k)
185 # but it's overkill for just that one bit of state.
186 def magic_deco(arg):
--> 187 call = lambda f, *a, **k: f(*a, **k)
188
189 if callable(arg):
/usr/local/lib/python3.7/dist-packages/IPython/core/magics/pylab.py in matplotlib(self, line)
97 print("Available matplotlib backends: %s" % backends_list)
98 else:
---> 99 gui, backend = self.shell.enable_matplotlib(args.gui.lower() if isinstance(args.gui, str) else args.gui)
100 self._show_matplotlib_backend(args.gui, backend)
101
/usr/local/lib/python3.7/dist-packages/IPython/core/interactiveshell.py in enable_matplotlib(self, gui)
3503 gui, backend = pt.find_gui_and_backend(self.pylab_gui_select)
3504
-> 3505 pt.activate_matplotlib(backend)
3506 pt.configure_inline_support(self, backend)
3507
/usr/local/lib/python3.7/dist-packages/IPython/core/pylabtools.py in activate_matplotlib(backend)
320 from matplotlib import pyplot as plt
321
--> 322 plt.switch_backend(backend)
323
324 plt.show._needmain = False
~/.local/lib/python3.7/site-packages/matplotlib/pyplot.py in switch_backend(newbackend)
274 backend_name = cbook._backend_module_name(newbackend)
275
--> 276 class backend_mod(matplotlib.backend_bases._Backend):
277 locals().update(vars(importlib.import_module(backend_name)))
278
~/.local/lib/python3.7/site-packages/matplotlib/pyplot.py in backend_mod()
275
276 class backend_mod(matplotlib.backend_bases._Backend):
--> 277 locals().update(vars(importlib.import_module(backend_name)))
278
279 required_framework = _get_required_interactive_framework(backend_mod)
/usr/lib/python3.7/importlib/__init__.py in import_module(name, package)
125 break
126 level += 1
--> 127 return _bootstrap._gcd_import(name[level:], package, level)
128
129
/usr/lib/python3.7/importlib/_bootstrap.py in _gcd_import(name, package, level)
/usr/lib/python3.7/importlib/_bootstrap.py in _find_and_load(name, import_)
/usr/lib/python3.7/importlib/_bootstrap.py in _find_and_load_unlocked(name, import_)
/usr/lib/python3.7/importlib/_bootstrap.py in _load_unlocked(spec)
/usr/lib/python3.7/importlib/_bootstrap_external.py in exec_module(self, module)
/usr/lib/python3.7/importlib/_bootstrap.py in _call_with_frames_removed(f, *args, **kwds)
~/.local/lib/python3.7/site-packages/matplotlib/backends/backend_qt5agg.py in <module>
9 from .. import cbook
10 from .backend_agg import FigureCanvasAgg
---> 11 from .backend_qt5 import (
12 QtCore, QtGui, QtWidgets, _BackendQT5, FigureCanvasQT, FigureManagerQT,
13 NavigationToolbar2QT, backend_version)
~/.local/lib/python3.7/site-packages/matplotlib/backends/backend_qt5.py in <module>
14 _Backend, FigureCanvasBase, FigureManagerBase, NavigationToolbar2,
15 TimerBase, cursors, ToolContainerBase, StatusbarBase, MouseButton)
---> 16 import matplotlib.backends.qt_editor.figureoptions as figureoptions
17 from matplotlib.backends.qt_editor._formsubplottool import UiSubplotTool
18 from . import qt_compat
~/.local/lib/python3.7/site-packages/matplotlib/backends/qt_editor/figureoptions.py in <module>
9
10 from matplotlib import cbook, cm, colors as mcolors, markers, image as mimage
---> 11 from matplotlib.backends.qt_compat import QtGui
12 from matplotlib.backends.qt_editor import _formlayout
13
~/.local/lib/python3.7/site-packages/matplotlib/backends/qt_compat.py in <module>
173 break
174 else:
--> 175 raise ImportError("Failed to import any qt binding")
176 else: # We should not get there.
177 raise AssertionError("Unexpected QT_API: {}".format(QT_API))
ImportError: Failed to import any qt binding
%% Cell type:code id: tags:
``` python
```
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment